d0s | Debian 6 — Apache2 — mod_rpaf + nginx: Invalid command ‘RPAFheader’ Go up
You are using an outdated browser. More... »
Posts d0s
1
2
3
Restarting web server: apache2Syntax error on line 5 of /etc/apache2/mods-enabled/rpaf.conf:

Invalid command 'RPAFheader', perhaps misspelled or defined by a module not included in the server configuration

*старая версия mod_rpaf

и это в релизе Debian 6 - УЖАС!..

Решение

1
2
3
4
5
aptitude install apache2-prefork-dev
wget stderr.net/apache/rpaf/download/mod_rpaf-0.6.tar.gz
tar xzf mod_rpaf-0.6.tar.gz
cd mod_rpaf-0.6
apxs2 -i -c -n mod_rpaf-2.0.so mod_rpaf-2.0.c

Теперь мы создали еще один модуль в составе апача, надо ему указать, что мы работаем именно с ним. Для этого редактируем файл /etc/apache2/mods-enabled/rpaf.load

1
LoadModule rpaf_module /usr/lib/apache2/modules/mod_rpaf-2.0.so

А в файле /etc/apache2/mods-enabled/rpaf.conf изменяем:

1
<IfModule mod_rpaf-2.0.c>

Спасибо lenar за подробную инструкцию..))

source: http://habrahabr.ru/post/120814/

Рубрики: Linux, Unix
Метки: , ,
No comments yet.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>